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Le Climate Predictability Tool (CPT) est un logiciel 

sous windows qui fait :

➢ Prévision saisonnière climatique 

➢ validation de modèle

➢ mise  à jour de la prévision 

Utilise des fichiers d’entrée en ASCII  

Options :

➢ Analyse en Composante Principale (PCR)

➢ Analyse en Corrélation Canonique (CCA)

Pages d’aide sur plusieurs sujets en format HTML

Option de sauvegarde des sorties en fichier ASCII ou 

sous format graphique JPEG

le code du programme source est maintenant 

disponible pour d’autres plateformes (exemple UNIX) 

INTRODUCTION 



3

Choisir l’analyse à faire : PCR ou CCA

CHOISIR UNE ANALYSE 
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Chacune de ses deux analyses nécessite 2 fichiers :

1. “X variables” ou “X Predictors” ;

et

2. “Y variables” ou “Y Predictands”.

FICHIERS D’ENTREE
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1. STATION files:

Ce type de fichier contient :

Nom_Station (sans espace; 

16 caractères)

Latitude (en degré)

Longitude (en degré)

Année (première colonne)

Donnée (missing values 

doivent être remplacée par la 

même valeur, -9999 par 

exemple)

Mots-clés :

STN, LAT, LONG

FORMAT DES FICHIERS D’ENTRÉE SUR CPT 
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2. Fichier indice ou sans 

référence :

Les données sont sans 

coordonnées (ni latitude et  

longitude): 

Nom_Indice (sans espace; 

16 caractères)

Année (première colonne)

Données (avec les valeurs 

manquantes)

Mots-clés :

NAME ou YEAR

FORMAT DES FICHIERS D’ENTRÉE SUR CPT 
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Les fichiers 

d’entrée peuvent 

être faits 

facilement an 

utilisant le logiciel 

Excel.

FORMAT DES FICHIERS D’ENTRÉE SUR CPT 
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FORMAT DES FICHIERS D’ENTRÉE SUR CPT 

Dans Excel le 

fichier doit être 

sauvegardé 

comme : “Text, 

tab delimited”.
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Pour sélectionner les fichiers d’entrée il faut cliquer sur 

browse.

SELECTION DES FICHIERS D’ ENTRÉE
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SELECTION DES FICHIERS D’ ENTRÉE

CPT ouvre un browser, qui par défaut regarde les fichiers d’entrée 

dans le répertoire :

C:\documents and settings\application\data\CPT\DATA\

Ou dans le répertoire spécifié lors de l’installation.

Tu peux chercher tes fichiers dans n’importe quel répertoire.
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Pour des données en grille ou station, CPT te propose 

le choix du domaine spatial sur lequel tu vas faire ton 

analyse en EOF ou CCA. En général ce domaine est 

connu à l’avance par ton expérience.

SELECTION DES FICHIERS D’ ENTRÉE
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Tu procèdes de la même manière pour sélectionner les 

fichiers contenants la variable Y (predictands). 

SELECTION DES FICHIERS D’ ENTRÉE
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Par défaut CPT commence l’analyse à partir de la première année dans les 

fichiers X ou Y; même si les années sont différentes. Tu devrais normalement 

choisir l’année la plus récente parmi ces deux fichiers.

Faire attention lorsque la saison est à cheval sur deux années comme par 

exemple les saisons DJF ou JFM. Dans ce cas l’année de début du fichier X 

doit être décalée d’une année par rapport à celle du fichier Y.

CHOISIR LA PERIODE D’APPRENTISSAGE 

(TRAINING PERIOD)
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Tu dois spécifier la longueur de la période d’apprentissage 

(training period) ainsi que la longueur de la fenêtre pour la 

validation croisée (cross-validation).

CHOISIR LA PERIODE D’APPRENTISSAGE 

(TRAINING PERIOD)
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Tu dois choisir le nombre de composante principale (EOF) du champ 

de prédicteurs à utiliser dans ton modèle. Si tu choisis un nombre 

minimum et un nombre maximum de EOFs, CPT choisit le nombre 

optimal entre les deux. Cependant si le minimum est égal au 

maximum CPT utilisera ce nombre exact de EOFs.

CHOISIR LES OPTIONS POUR L’ANALYSE
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Si tu as des données manquantes dans tes fichiers, tu dois 

spécifier à CPT ce qu’il doit en faire.

DONNEE MANQUANTES - MISSING VALUES
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Près du choix Missing value flag, tu dois spécifier le chiffre qui représente une donnée 

manquante.

Tu peux fixer le pourcentage maximal de donnée manquante avec maximum % of 

missing values. Si une station ou point a plus que ce pourcentage de donnée 

manquante, CPT ignorera cette station ou point lors de l’analyse.

Tu peux aussi choisir une méthode de remplacement de toute donnée manquante avec 

le menu Maximum value Replacement.

DONNEE MANQUANTES - MISSING VALUES
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Une fois que les fichiers sélectionnées de même que les choix faits il est 

bon de sauvegarder ces choix dans un projet pour les appeler plus tard 

avec : File => Save

Par défaut, CPT sauvegarde tous les fichiers projet dans le sous répertoire : 

C:\documents and settings\application\data\CPT\Projects\

SAUVEGARDE DES CHOIX DE L’ANALYSE 
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Maintenant tu peux commencer ton analyse en allant aux 

menus : Actions => Calculate => Cross-validated

LANCER L’ANALYSE 
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ANALYSE DES DONNEES

CPT commence l’analyse sur une nouvelle fenêtre “Results Window” 

sur laquelle tu peux voir les étapes et les procédures d’optimisation.
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ANALYSE DES DONNEES

Optimisation du nombre de EOF :

1. CPT utilise d’abord EOF 1 comme prédicteur pour faire une validation 

croisée et ensuite il calcule un indice de bonne prévision “goodness index” 

indiquant la qualité de la prévision en général (L’échelle 1 étant la meilleur). 

Ensuite CPT utilise les EOF1 et EOF2 pour faire la prévision cross-validated 

et calcule à nouveau le goodness index, et ainsi de suite jusqu’à utiliser tous 

les 4 EOFs.

2. A chaque étape CPT compare les goodness indices et retient dans la 

colonne “OPTIMUM” le meilleur indice et le nombre de EOFs utilisé. (voir 

l’exemple ci dessus).

3. CPT utilise ce nombre d’EOFs (i.e. 1) pour construire le modèle.



22

Le menu :  Tools => Graphics => Scree plots

Permet d’afficher le pourcentage de variance associée à

chaque EOF.

RESULTATS : graphiques
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1. Le menu  Tools => Graphics => X EOF loadings and scores

Montre loading pattern de chaque EOF et sa série temporelle.

2. CPT te permet de faire des modifications et de sauvegarder chaque 

graphe :  en cliquant sur le bouton droit de la souris en sélectionnant le 

graphe  à changer ou sauvegarder 

RESULTATS : graphiques
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Pour changer le titre du graphe :

1. cliquer sur le bouton droit de la souris

2. aller á EOF Loadings

3. cliquer sur Title

CHANGER LE TITRE 
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Tu peux spécifier le nom du fichier du graphe en cliquant sur 

browse. Tu peux ajuster la qualité du graphe JPEG.

Tous les fichiers de sorties seront sauvegardé par défaut dans : 

C:\documents and settings\application\data\CPT\Output\

SUVEGARDER LES GRAPHES
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Si tu veux obtenir une meilleure résolution, tu peux changer l’option 

graphique à une haute résolution : 

Customize => Graphics => High Resolution Map 

AFFICHER DES CARTES A HAUTE  RESOLUTION
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Pour voir les résultats il faut aller au menu “Tools”:

Validation : montre le skill et les séries prévues (hindcasts) et observées.

Contingency Tables : montre les tables de contingence.

Graphics : montre les séries temporelles des EOFs, les loading patterns et                    

le  scree plot

RESULTATS
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RESULTATS

Pour voir les séries prévues (forecasted) et observées à chaque point de mesure il 

faut aller à : 

Tools => Validation => Cross-Validated => Performance Measures

Ce menu montre quelques statistiques sur la prévision comme coefficient de 

corrélation, RMSE, ROC etc (pour plus de détails voir la page d’aide).
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Customise => Graphics => Reverse Colors

Si par exemple tu prévois température au lieu de précipitation, alors il est 

plus indiqué d’avoir le rouge pour chaud/au-dessus et le bleu pour froid/au-

dessous pour cela il faut intervertir les couleurs par défaut. Si tu préféres 

avoir les couleurs en noir et blanc pour par exemples incorporer l’image 

dans un rapport : Customise => Graphics => Black and white

ECHANGER LES COULEURS
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Pour avoir des indications d’incertitudes sur la performance des 

mesures il faut aller à : 

Tools => Validation => Cross-Validated => Bootstrap

INDICATIONS D’INCERTITUDE
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Customize => Resampling Settings

CPT te permet de choisir options du bootstrap.

ADJUSTING THE BOOTSTRAP SETTINGS
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Le menu File => Data Output permet de sauvegarder les données            

de sortie dans un fichier : 

1. EOFs: séries temporelles, loading patterns, variance

2. Les paramètres (coefficients) du modèle (exemple: Y=Ax+b)

3. Les données d’entrée (avec les missing values complétées)

4. Les séries temporelles de la prévision Cross-validated

RESULTATS : fichier de donnée.
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Pour pouvoir sauvegarder les sorties dans des fichiers séparés, 

tu dois spécifier un nom de fichier en cliquant sur browse. Par 

défaut CPT sauvegarde les fichiers de sortie dans  : 

C:\documents and settings\application\data\CPT\Output\

SAUVEGARDER LES FICHIERS DE SORTIE 
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Une fois que le modèle est fait, tu peux faire une 

prévision réelle en utilisant un fichier de prédicteurs 

mis à jour : 

File => Open Forecast File

PREVISON - FORECAST
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Une nouvelle fenêtre sera ouverte. Par défaut CPT 

sélectionne le même fichier prédicteur. 

Tu peux le changer en cliquant sur browse.

PREVISON - FORECAST
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Tu peux alors sélectionner : 

(a) l’année à partir de laquelle la prévision commence

(b) le nombre d’année à prévoir

PREVISON - FORECAST
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Une fois le fichier est sélectionné et les années à

prévoir choisies il faut aller au menu : 

Tools => Forecast => Series ou Maps.

PREVISON - FORECAST
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L’option Séries montre les valeurs prévues (en croix) à la station 

choisie de même que les prévisions possibles, l’intervalle de confiance 

de la prévision et dans le carré “Thresholds”, les limites (thresholds) et 

la probabilité assignées à chaque catégorie.

Below Normal

Above Normal

Valeur

Prévue

PREVISON - FORECAST
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Il y’a deux manières de 

changer les catégories. La 

première est de changer les 

probabilités climatologique. 

Customize => Thresholds

CHANGER LES CATEGORIES

CPT recalcule les 

limites (thresholds)
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La deuxième manière 

est de fixer les limites 

(thresholds).     

CPT recalcule les 

probabilités 

climatologiques.     

CHANGER LES CATEGORIES
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Pour afficher des barres d’erreur (error bars) sur la prévision, cliquer sur le 

bouton droit sur le graphe : 

Customize => Prediction Intervals 

Une barre d’erreur sera affichée.

INTERVALLES DE PREVISION 
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Tu peux aussi changer la longueur de l’intervalle de la 

prévision.     Customize => Forecast Settings 

L’option par défaut est de 68.2% ce qui donne une barre 

d’erreur standard.

CHANGER L’INTERVALLE DE LA PREVISON 
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La prévision peut être exprimée en anomalie au lieu de valeur 

entière  par : 

Customize => Forecast Settings => Anomalies 

EXPRIMER LA PREVIONS EN ANOMALIE
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Les limites (thresholds), ainsi que les catégories de la prévision 

sont maintenant exprimées en anomalie.

EXPRIMER LA PREVIONS EN ANOMALIE
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SAUVEGARDER LA PREVISION

Pour sauvegarder la prévision, cliquer avec le bouton droit 

de la souris et spécifier le format du fichier de sortie.
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CHANGER LA PERIODE DE LA CLIMATOLOGIE.

Par défaut, les probabilités de la prévision sont calculées par 

rapport à une période climatologique qui est la même que la 

training période. Pour changer la période de la climatologie aller à

: Customise => Climatological Period
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Tools => Forecast => Maps

L’option Maps te permet de 

voir les cartes prévues – soit 

des cartes des probabilités 

soit des cartes des valeurs 

prévues. 

Les cartes de prévision 

probabilistique montre la 

probabilité de chaque 

catégorie à chaque point ainsi 

que la distribution spatiale de 

la prévision.

Sur cette exemple il est 

évident de noter que pour 

2000 la catégorie below-

normal à la plus faible 

occurrence au Brésil du Nord. 

CARTES PREVUES
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Le forecast montre la 

liste des valeurs 

prévues pour chaque 

catégories à chaque 

point ainsi que la 

distribution spatiale de 

ces valeurs.

CARTES PREVUES
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Pour afficher la 

probabilité du seuil de 

dépassement il faut 

aller du seuil de 

dépassement á :  

Tools =>Forecast => 

Exceedances

PROBABILITIE du seuil de dépassement
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• Pour plus de détails, lire la page d’aide sur chaque 

menu et sur chaque option.

• Souscrire á la liste des utilisateurs pour être notifié 

aux mise á jour : 

http://iri.columbia.edu/outreach/software/

CONCLUSIONS
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www.acmad.org 


